Some initial queries to infrequently read namespaces incorrectly returning empty results

Incident Report for Pinecone

Resolved

This incident has been resolved.
Posted Jun 18, 2026 - 18:23 UTC

Investigating

We are currently investigating this issue.
Posted Jun 18, 2026 - 10:00 UTC
This incident affected: Serverless Indexes (AWS us-west-2, AWS eu-west-1, Azure eastus2, GCP us-central1, GCP europe-west4).