[Serverless][AWS][us-east-1] Indexing lag on some indexes; recent writes may not appear in reads

Incident Report for Pinecone

Resolved

This incident has been resolved.
Posted May 28, 2025 - 02:50 UTC

Investigating

We are currently investigating this issue.
Posted May 28, 2025 - 02:25 UTC
This incident affected: Serverless Indexes (AWS us-east-1).