[Serverless][AWS][us-west-2] 5xx errors on the readpath

Incident Report for Pinecone

Monitoring

We are recovering and are monitoring to ensure no further errors occur.
Posted Sep 17, 2026 - 06:14 UTC

Investigating

We have identified the issue and we are in the process of mitigating.
Posted Sep 17, 2026 - 05:37 UTC
This incident affects: Serverless Indexes (AWS us-west-2).