Intermittent unavailability across all environments for some indexes

Incident Report for Pinecone

Resolved

This incident has been resolved.
Posted Jan 02, 2026 - 17:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 02, 2026 - 17:18 UTC

Investigating

We are currently investigating this issue.
Posted Jan 02, 2026 - 16:31 UTC
This incident affected: Pod Indexes (us-west1-gcp, us-east1-gcp, us-central1-gcp, us-west4-gcp, us-east4-gcp, us-west1-gcp-free, us-west4-gcp-free, gcp-starter, eu-west1-gcp, eu-west4-gcp, asia-southeast1-gcp, asia-northeast1-gcp, asia-southeast1-gcp-free, northamerica-northeast1-gcp, eastus-azure, us-east-1-aws), Console, Index Management, Inference, Assistant, and Serverless Indexes (AWS us-west-2, AWS us-east-1, AWS eu-west-1, Azure eastus2, GCP us-central1, GCP europe-west4).