[GCP][us-central1][europe-west4] Errors on some read operations

Incident Report for Pinecone

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 01:52 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 24, 2026 - 01:09 UTC

Monitoring

The impact was related to a Google Cloud Storage incident (Event ID: WDVVRMB).
Posted Feb 24, 2026 - 01:08 UTC

Investigating

We are currently investigating this issue.
Posted Feb 23, 2026 - 23:14 UTC
This incident affected: Serverless Indexes (GCP us-central1, GCP europe-west4).