Google Cloud outage impacting all GCP clusters, Inference, Assistant, and control plane operations; console elements failing to load

Incident Report for Pinecone

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 02:04 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 23:13 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 17:56 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 17:55 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 17:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 12, 2025 - 17:55 UTC
This incident affected: Pod Indexes (us-west1-gcp, us-east1-gcp, us-central1-gcp, us-west4-gcp, us-east4-gcp), Console, Index Management, Inference, Assistant, and Serverless Indexes (GCP us-central1, GCP europe-west4).